[Quick-Tip] LaTeX Error: File `titlesec.sty’ not found en Gentoo

Luego de una actualización de rutina (emerge world+emerge depclean) mi editor favorito Tex me presentaba el error «! LaTeX Error: File `titlesec.sty'» al compilar algunos articulos. Luego de revisar dependencias note que TeXstudio solo depende del paquete virtual virtual/latex-base para marcar la dependencia de LaTeX.

La mayoria de usuarios en Gentoo utiliza texlive como su distribución Tex y habiendo migrado entre varios editores supongo que mi sistema quedo con un paquete huérfano que incluía titlesec.sty y que fue eliminado con emerge depclean solo quedándome con texlive-core y mucha frustración por no poder compilar mis archivos Tex.

¿Solucion?

La mayoria de blogs recomienda instalar texlive completo sin embargo en Gentoo basta con texlive-latexextra y con un

emerge texlive-latexextra

El problema esta resuelto. ¿Porque no instalar todo texlive?, Pues basicamente porque la combinación texlive-extras+texlive-core es más pequeña y el control atómico de paquetes y dependencias en Gentoo es maravilloso.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *